Docker containers within a workspace fail to start or build

Incident Report for Gitpod

Resolved

The issue has been successfully mitigated.
Posted Aug 27, 2021 - 07:30 UTC

Monitoring

- We have implemented a mitigation and docker-in-docker / docker-compose scenarios are now working once again.
- Restarting of existing workspaces is required to obtain the mitigation.
- A permanent solution is under development at https://github.com/gitpod-io/gitpod/issues/5171
Posted Aug 27, 2021 - 06:37 UTC

Identified

Starting or building docker containers within a workspace (ie. docker-in-docker and docker-compose) is currently not working. We're currently investigating the issue, and will provide an update soon.
Posted Aug 27, 2021 - 03:43 UTC
This incident affected: [PAYG] Workspaces.